Cách khắc phục lỗi pluggable.php trong WordPress

Bạn đang gặp lỗi file pluggable.php trên trang WordPress của mình? Lỗi này thường xảy ra khi bạn chèn thêm một đoạn mã trên website của bạn hoặc kích hoạt một plugin mới. Trong bài viết này, chúng tôi sẽ hướng dẫn cho bạn cách sửa lỗi file pluggable.php trong WordPress.

Khi nào và tại sao bạn thấy lỗi pluggable.php?

WordPress cho phép người dùng và plugin ghi đè các chức năng cốt lõi nhất định. Các hàm này được đặt trong file pluggable.php.

Nếu một plugin WordPress hoặc một đoạn mã đã cài đặt không xử lý chính xác một trong các chức năng thì bạn sẽ thấy lỗi như thế này:

Warning: Cannot modify header information – headers already sent by (output started at /home/username/demosite/wp-content/themes/mytheme/functions.php:1035) in /home/username/demosite/wp-includes/pluggable.php on line 1179

Đôi khi, bạn có thể tiếp tục thao tác trên trang web của mình dù lỗi này hoặc một số lỗi khác vẫn xuất hiện trong khu vực quản trị.

Vậy chúng ta hãy cùng xem làm thế nào để dễ dàng sửa lỗi file pluggable.php trong WordPress.

Sửa lỗi file Pluggable.php trong WordPress

File pluggable.php là một file WordPress cốt lõi. Bạn không bao giờ nên chỉnh sửa các file dạng này, ngay cả khi thông báo lỗi trỏ đến chúng.

Trong hầu hết các trường hợp, lỗi này đến từ một vị trí khác.

Để khắc phục bất kỳ lỗi nào đề cập đến file pluggable.php, chỉ cần nhìn vào vị trí đầu tiên được đề cập trong lỗi.

Warning: Cannot modify header information – headers already sent by (output started at /home/username/demosite/wp-content/themes/mytheme/functions.php:1035) in /home/username/demosite/wp-includes/pluggable.php on line 1179

Trong ví dụ trên, lỗi nằm ở của file functions.php của theme tại dòng 1035.

Điều này có nghĩa là: bạn cần chỉnh sửa file functions.php của theme và sửa lại hoặc xóa hẳn đoạn mã gây ra lỗi này.

Đôi khi lỗi nằm ngay ở phần đầu của file, thường do một khoảng trống thừa sau khi đóng thẻ php?>, Vì vậy bạn chỉ cần xóa nó đi thì vấn đề sẽ được khắc phục.

Hãy xem một ví dụ khác:

Warning: Cannot modify header information – headers already sent by (output started at /home/username/demosite/wp-content/plugins/some-plugin-name/some-plugin.php:144) in /home/username/demosite/wp-includes/pluggable.php on line 1090

Thông báo lỗi này đang trỏ đến một plugin trên trang WordPress của bạn gây ra lỗi. Trường hợp này, bạn nên tắt plugin và thông báo cho tác giả plugin về lỗi nó gây ra.

Trong hầu hết các trường hợp, lỗi đề cập đến file pluggable.php không phải do chính file đó gây ra.

Những lỗi này thường do một đoạn mã cài đặt mà bạn đã thêm vào file functions.php, hoặc một plugin được lập trình kém, hay thậm chí là theme WordPress của bạn .

Chỉ cần xóa hoặc chỉnh sửa các đoạn mã mới được thêm vào hoặc tắt plugin, lỗi sẽ không còn nữa.

Đọc đến đây mà bạn vẫn không thể tìm ra nguyên nhân gây ra những lỗi này?

Hãy làm theo các bước trong hướng dẫn chi tiết của chúng tôi về khắc phục lỗi trên WordPress . Bạn sẽ tìm ra nguyên nhân gây ra lỗi và cách khắc phục nhanh chóng.

Chúng tôi hy vọng bài viết này đã giúp bạn giải quyết các lỗi liên quan đến file pluggable.php trong WordPress. Bạn cũng có thể muốn lưu lại bài viết của chúng tôi về danh sách các lỗi phổ biến nhất của WordPress và cách khắc phục chúng .

Nếu bạn thích bài viết này thì vui lòng đăng ký Kênh YouTube của chúng tôi để xem video hướng dẫn. Bạn cũng có thể tìm thấy chúng tôi trên Twitter và Facebook .

Leave a Reply

Your email address will not be published. Required fields are marked *

+